SAP Knowledge Base Article - Public

2918263 - Candidates receive RMK job alerts to the wrong email address and cannot change it - Recruiting Marketing

Symptom

Candidates created their profile with an email address and even though they changed this address in RCM they are not able to change the address they are receiving RMK job alerts on to the new one.

Environment

  • SAP SuccessFactors Recruiting Marketing
  • SAP SuccessFactors Recruiting Management

Cause

When Recruiting Marketing (RMK) is integrated with Recruiting Management (RCM), the Candidate Account Simplification (CAS) feature is used to synchronize the candidate account between RMK and RCM.

RCM is where the profile is hosted. When a candidates logs into their profile they are actually logging into RCM, not RMK.
Changes to the profile are not possible from RMK itself but are synchronized from RCM.

There are however differences between RCM and RMK in terms of email management : RMK only has one email field when RCM has two : Primary Email and Contact Email so this can cause discrepancies.

Resolution

Only the Primary email is synched to RMK.
The Primary email cannot be changed in RCM, so the email used by RMK to send out alerts cannot be updated.
This means RMK alerts can only be sent to the original email address.
Changing the contact emails in RCM has therefore no effect on RMK job alerts.

The candidate must create a new account with the new email in order to receive alerts to the new email address.

If you think this should be enhanced, please refer to KBA 2090228 to raise an enhancement request.

See Also

2652205 - What is Candidate Account Simplification - Recruiting Marketing

2090228 - How to Submit Enhancement Requests for SAP SuccessFactors Products

Keywords

Recruiting Marketing, candidate, email, login, job, alert, rmk, cas, update, change , KBA , LOD-SF-RMK-INT , Int with RCM, Data Mapping, AwLi, Multilocation posting , Problem

Product

SAP SuccessFactors Recruiting all versions