SAP Knowledge Base Article - Public

2918364 - HTTP 404 accessing GetServerInfo after Live Data Connect webapp deployment

Symptom

This KBA relates to the legacy version LUC 2.x only. It is heavily recommended to upgrade to LUC 3.x for Full Support and for a much simpler deployment process.

  • The following error is seen when accessing https://<HOST>:<PORT>/sap/boc/ina/GetServerInfo after deploying the SAP Analytics Cloud (SAC) Live Data Connect (LDC) web application on tomcat:
    HTTP Status 404 – Not Found
    Type Status Report
    Message /sap/boc/ina/GetServerInfo
    Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

  • If deploying the web application through the Tomcat manager app, the below message may be seen:
    FAIL - Deployed application at context path [/sap/boc/ina] but context failed to start

  • In the tomcat stderr.log (Available at tomcatdir/logs), the following error is seen:

    Apr 23, 2020 1:55:49 PM org.apache.catalina.core.StandardContext startInternal
    SEVERE: One or more listeners failed to start. Full details will be found in the appropriate container log file
    Apr 23, 2020 1:55:49 PM org.apache.catalina.core.StandardContext startInternal
    SEVERE: Context [/sap/boc/ina] startup failed due to previous errors

  • In the localhost.<DATE>.log, the following error is seen:

    08-Apr-2020 12:47:05.828 SEVERE [https-jsse-nio-8444-exec-2] org.apache.catalina.core.StandardContext.filterStart Exception starting filter [CorsFilter]
    javax.servlet.ServletException: It is not allowed to configure supportsCredentials=[true] when allowedOrigins=[*]
    at org.apache.catalina.filters.CorsFilter.parseAndStore(CorsFilter.java:729)
    at org.apache.catalina.filters.CorsFilter.init(CorsFilter.java:183)

Environment

  • SAP Analytics Cloud
  • Live Data Connect (LDC) / Live Universe Connector (LUC) 2.x

Reproducing the Issue

  1. Deploy LUC on Tomcat following the documentation
  2. Observe the application is not accessible at https://<HOST>:<PORT>/sap/boc/ina/GetServerInfo 

Cause

The CorsFilter has not been configured correctly.

Resolution

  1. Navigate to TOMCATDIR\webapps\sap#boc#ina\WEB-INF
  2. Open web.xml 
  3. Search for:

    <init-param>
    <description>A comma separated list of allowed origins. Note: An '*' cannot be used for an allowed origin when using credentials.</description>
    <param-name>cors.allowed.origins</param-name>
    <param-value>*</param-value>
    </init-param>

  4. Configure it as below:
    <init-param>
    <description>A comma separated list of allowed origins. Note: An '*' cannot be used for an allowed origin when using credentials.</description>
    <param-name>cors.allowed.origins</param-name>
    <param-value>https://example.SAC.tenant.com</param-value>
    </init-param>

    Note: Ensure there is no trailing backslash after the URL

  5. Restart Tomcat, or start the webapp again through the Tomcat manager application

See Also

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Keywords

 SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC , KBA , LOD-ANA-LDC , SAC Live Data Connection , Problem

Product

SAP Analytics Cloud all versions