Symptom
Ticket is created from an incoming e-mail with the wrong account.
Environment
SAP Cloud for Customer
Reproducing the Issue
A contact is assigned to two different Accounts, Account ABC and Account DEF (ABC and DEF represents the Account ID's). An incoming e-mail from the contact comes in the system, and Account ABC is assigned to the Ticket while you expect Account DEF to be maintained in the ticket, as the contact has the Main flag for Account DEF.
Cause
When a contact is associated with multiple accounts:
- If the same e-mail address is maintained for all the relationships with the account, the system considers the account randomly, and not based on any indicator.
- If different e-mail addresses are maintained for account relationships, the system considers the account as per the sender e-mail.
Resolution
Currently the system is not considering any indicator, like the main indicator to select the account. This is the standard behavior of the system.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
e-mail, email, account, ticket, main , KBA , LOD-CRM-SRP , Service Request Processing , How To