SAP Knowledge Base Article - Public

2920664 - Manually Changing a Party Role Does Not Trigger The Automatic Re-Determination in Ticket Involved Parties

Symptom

You would like to understand the reason why the system does not automatically re-determine party roles for Ticket Involved Parties when a manual change or the addition of another party role happens.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Service work center.
  2. Navigate to Tickets work center view.
  3. Open any ticket.
  4. Navigate to Involved Parties tab.
  5. Click Edit.
  6. Manually change an existing party role / add a new one.
  7. See the system does not re-determine it automatically based on the criteria previously defined.

Cause

When you manually change or add a party role in the ticket, the system designed behavior is to not re-determine it since manual changes have higher priority over automated changes in the system logic.

Resolution

This is the system designed behavior.

A possible approach is to use the action Re-determine Completely in the Involved Parties tab, which ignores manual changes and therefore reset any change / addition made.

Keywords

Involved Parties; Party Role; Ticket; Manual; Automatic; Change; Re-determined; Redetermine Completely; Action; Service Request; C4C; Cloud for Customer; Service; , KBA , LOD-LE-RC-PAP , Party Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions