Symptom
You have added embedded reports to the Account TI and you have made them available for the Account Summary. However, after generating the PDF, you notice that your embedded report is not shown there.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the work center Customers and the view Accounts.
- Open your account.
- Enter the adaptation mode and add your embedded report.
- Make sure that you enable it for the summary by using the toggle button.
- Save this change. You can now see a report in this account.
- Click Summary.
- In the pop-up, select the Account Summary template and click Open.
- The PDF is generated.
You notice that the PDF file does not show the embedded report.
Cause
There are 2 possible causes:
- The embedded report has no data.
- The template Account Summary was changed and all embedded reports were removed from the layout.
Resolution
- Empty reports will not be shown on the account summary.
- Make sure that the template contains the embedded report sections by following the steps below:
- Go to the work center Administrator.
- Select the view Form Template Maintenance.
- Search for the Account Summary template.
- Choose the respective language and open the template.
- The embedded reports will be included in the Marketing Attributes sections. For all embedded reports to be included, make sure that all sections with the label Marketing Attributes are used - there needs to be more than 1 section with this label.
See Also
Keywords
embedded report, account summary, form template, missing report, reporting, pdf , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions