SAP Knowledge Base Article - Public

2921452 - Token does not appear highlighted in yellow in Manage Recruiting Email Templates - Recruiting Management

Symptom

A token in an email template does not appear highlighted in yellow so is not recognized as a token.

The issue persists also if you try to delete and add the token again.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

1. Open an email template from Manage Recruiting Email Templates tool

2. Use the appropriate tool to add a token from the list

3. Issue: the token does not appear highlighted in yellow and if you test generating an email you will see that is not working

Cause

Possible incorrect input.

Resolution

  1. Click on "Source" button to access the source of the template
  2. If the line of the affected token appears as following: <p>Location:&nbsp;<span data-mce-contenteditable="false">[[INTERVIEW_SCHEDULING_INTERVIEW_LOCATION]]</span>&nbsp;</p> edit the code to remove part of the text: <p>Location: [[INTERVIEW_SCHEDULING_INTERVIEW_LOCATION]]</p>
  3. Save the template

Now the token show appear highlighted in yellow, this means that is recognised by the system as a token and it will work.

Keywords

token not recognised, token not highlighted in yellow , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions