SAP Knowledge Base Article - Public

2922088 - The Ticket Object Value Selector at the Customer Field Fetches Wrong Data

Symptom

When using the Object Value Selector at field Customer in the Ticket TI, you can see restricted accounts, although restrictions have been set.

 "Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customer work center
  2. Go to the Accounts view
  3. Query ALL
  4. Observe the count is ABC (ABC stands for the total count of the accounts)
  5. Go to the Ticket work center
  6. Open any ticket with status Open
  7. Edit
  8. Open the Object Value Selector at the Customer field
  9. Observe the count is DEF (DEF stands for the total count of the accounts)
  10. ABC is different to DEF, but it's expected to be the same

Cause

The ticket TI (/BYD_COD/ServiceOnDemand/Collaboration/COD_SR_TI. TI. component) is delivered with 3 different input fields for the customer selection:

1. Label "Customer" (the field is currently visible in your system) with object value selector /BYD_COD/ServiceOnDemand/AgentQueue/Customer_OVS. OVS. component. This object value selector does currently not honor customer/account instance restrictions

2. Label "Account" (personalization hidden) with object value selector /BYD_COD/SalesOnDemand/Account/UI/COD_Account_SOVS. OVS. component. This object value selector does honor the customer/account instance restrictions

3. Label "Individual Customer" (personalization hidden) with object value selector /BYD_COD/ServiceOnDemand/AgentQueue/Individual_Customer_OVS. OVS. component. This object value selector does currently not honor customer/account instance restrictions

Resolution

If you want to have an instance restriction in this field you have to make the field '2' visible via KUT and hide the field '1'.


field_2 visible_via_KUT.png

Keywords

Object Value Selector, Ticket OVS, Account OVS, Account restrictions, Ticket Restrictions , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2002