SAP Knowledge Base Article - Public

2922471 - Unable to Change the Status of a Business Partner to Obsolete Which has the Role Employee

Symptom

You have a requirement to obsolete a Business Partner which has the role Employee but the status such as Block and Obsolete are greyed out

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Business Partner work center
  2. Highlight the Business Partner which has the role Employee
  3. Select Change Status button

Block and Obsolete options are greyed out

Cause

The Status of internal Employees can not be changed on any screen in the C4C system. This is an intentional design decision and thats the reason why the 'Change Status' options are disabled in the Business Partner OWL for internal Employees.

Resolution

The equivalent of setting an internal Employee to 'Obsolete' is to delimit its validity period. One could also argue that the 'Obsolete' status in all other Business partner entities (Accounts, Contacts, etc...) is a sort of workaround since they have to time dependency.

If this solution doesnt suffice your requirement then the option to destroy the internal Employee in the 'Data Protection and Privacy' work center on the work center view 'Personal Data Removal'

Keywords

employee status change, obsolete, internal employee, personal data , KBA , LOD-LE-BP-BP , Business Partner , LOD-CRM-EMP , Employee , Problem

Product

SAP Cloud for Customer core applications all versions