SAP Knowledge Base Article - Public

2922917 - Enabling Fuzzy Search in People Search

Symptom

  • How to enable Fuzzy Search?
  • How to disable Fuzzy Search?
  • Why when I search by a user I am able to see many values/answers?

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Under Action Search, you search for a single username;
  2. System is showing the username you searched, however is showing as well several others values:

Cause

If you face the behavior informed above, it means the Fuzzy Search is enabled in your environment.

Resolution

  • How to enable and disable Fuzzy Search?

Please, follow the instructions Enabling Fuzzy Search in People Search to get the steps.

  • Why when I search by a user I am able to see many values/answers?

You are seeing too many values, because Fuzzy Search is enabled in Company System and Logo Settings. If you wouldn't like to this behavior under Action Search, please, disable the Fuzzy Search (steps are in the Enabling Fuzzy Search in People Search).

Important highlight: as of the current moment, Japanese Language isn't fully supported by Fuzzy Search.

  • If you're using Japanese language, please be aware that the the Fuzzy Search will see the Japanese Kanji symbols "splitted up", therefore, the search will also bring up, among with the results, some users that don't match the complete search value, but still match one of the Kanji symbols that are part of the entire search keyword, what can show confuse results (such as users that only match one Kanji appearing above users that match all of them).

See Also

Enabling Fuzzy Search in People Search

Keywords

japanese, japanese kanji, kanji, several search values, too many values for one username, display relevant employee names instead of exact matches in People Search, , KBA , LOD-SF-PLT-SRH , Search , How To

Product

SAP SuccessFactors HXM Suite 2011