SAP Knowledge Base Article - Public

2923091 - Error: National ID XYZ already exists for country/region ABC and card type MNP

Symptom

When adding/saving national ID information for an employee, you receive the error: National ID XYZ already exists for country/region ABC and card type MNP.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to profile of a user and edit National ID portlet
  2. In the National ID portlet, either edit an existing national ID value or enter a new record
  3. Fill up all necessary fields and Save
  4. You receive the error: National ID XYZ already exists for country/region ABC and card type MNP. Here, XYZ is the entered national ID value, ABC is the country/region for which the value is entered and MNP is the national ID card type.

Cause

There is another employee with this national ID value XYZ for the country/region ABC and national ID card type MNP. 

Resolution

The system will not accept duplicated National IDs and this is hard coded. Currently it is not possible to disable this check.

You can find which user already has this national ID by either of the following 2 methods:

  • Using Canvas report: Check Duplicated National ID : 3567443 - How To Retrieve National ID Record In Canvas Report
  • Using Integration Center: Please follow these steps:
    1. Go to Admin Center > Integration Center
    2. Click on My Integrations
    3. Click on Create and select Scheduled Simple File Output Integration
    4. Search for National ID Information (PerNationalId) entity and select it
    5. Under Data Preview, select columns National Id Card Type (cardType), Country (country), Person ID External (personIdExternal) and National Id (nationalId) and click on Select
    6. Click on Filter and Sort > Advanced Filters
    7. Select National Id from Field's drop-down
    8. Keep Operation "is equal to" and copy+paste the national ID value that you're trying to enter in the field Value. In our example, the value is XYZ
    9. Click on Configure Fields to see which user already has the national ID value XYZ. Please note that you get the validation message in National ID portlet only when the national ID value, the card type and country/region are same. 

If you cannot find the user with duplicate/existing national ID entry, it may be that the national ID has been used for an inactive onboardee user. You may need to purge this onboardee if you want to use the same national ID value. You can refer to the KBA for DRTM Onboarding Purge details. However, if you need more help regarding onboardee purge, please reach out to Onboarding team (LOD-SF-OBX). 

It also may be that the national ID data still exists for a deleted/purged user. In this case, Compound Delete import must be performed as per the following KBA to correct the data issue: How to delete an orphaned Person ID with Compound Delete functionality.

See Also

Keywords

rule, nationalId, CRES, certificado de reservista, validation, check, validate, duplicate, duplication, same, copy, identical, report, onboardee, orphan, compound , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central 2411 ; SAP SuccessFactors HCM Suite all versions