Symptom
A user has suddenly less or no email templates available to select when emailing a candidate. Previously, this user used to have all email templates, that are permissioned to the user's role, available to select.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting
- Select a candidate you want to send an email
- There are less or no email templates than expected, some or all are missing
OR
- Go to Admin Centre > Manage Permission Roles
- Select the role of the affected user
- Go to Permissions > Recruiting Email Templates
- Only some or no email templates are listed, some or all are missing
Before you could see all email templates listed that are translated in your system language
Cause
The user might have switched the language (i.e. German) to another one (i.e. English US). When switching the language back to German, the system shows only those email templates that are translated in English US (en_US). If no email templates are translated in English US (en_US), the system will show no email templates available.
Resolution
This is a cache issue.
- Log out from your instance
- Clear your broswer data and delete your cache
- Close the browser and restart a new session
- Log in again
- You will see that all the email templates translated in the language of your locale and permissioned to you are available again to be selected
See Also
2867556 - A number of Recruiting Email templates are missing in Manage Permission Roles
Keywords
Recruiting email templates, permission, role, access , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem