Symptom
You are replicating Business Partner to Cloud for Customer, incoming message fails with error "CUSTOMER role for business partner XYZ missing" where XYZ is the Customer/Individual Customer ID
Environment
SAP Cloud For Customer
Reproducing the Issue
1) Go to Webservice Message Monitoring
2) Highlight the failed message with "BusinessPartnerReplicationIn" or "BusinessPartnerERPReplicationIn"
3) Navigate to Error Log , the error is displayed "CUSTOMER role for business partner missing XYZ"
Cause
You have already replicated XYZ as an Individual Customer or Customer to C4C. However in the delta update message, you are not sending a CUSTOMER related role code under "BusinessPartnerRoleCode".
Resolution
Send the CUSTOMER related role code for the message to get processed successfully. To check the role codes available, below are the steps
1) Go to Business Configuration workcenter
2) Go to Overview
3) Open the Activity "Accounts"
4) Open the link "Maintain Customer Roles"
5) Here you can see the list of roles available for which code list mapping needs to be maintained
6) You need to send the external code of the role thats already available on the Customer/Ind Customer or any other external code mapped to one of the above local codes so that message will be processed successfully
Keywords
"CUSTOMER role for business partner missing" "BusinessPartnerReplicationIn" "BusinessPartnerERPReplicationIn" "C4C Customer" "C4C Individual Customer" "C4C Contact" , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-CRM , Integration of C4C with CRM , Problem