SAP Knowledge Base Article - Public

2924836 - Renewal Rule is Not Editable on Customer Contract Item

Symptom

You have selected a Renewal Rule in the contract header, it copies into the items. But you find Renewal Rule field in the Item level is grayed out, you are not able to remove it.

Environment

SAP Business ByDesign 2005 onwards

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Go to the Contracts view.
  3. Find the contract ABC and go to General - Renewal and Cancellation tab. Renewal Rule <XYZ> is maintained.
  4. Go to the Items tab, select one line, the Renewal Rule is filled with <XYZ> as well, but it is grayed out. 

ABC represent the ID of a contract, XYZ represents the ID of a renewal rule.

Cause

In the renewal rule <XYZ>, you have selected Create New Contract' option. In this case, the rule will renewal the entire contract, hence the change on item level is not allowed. If the option of 'Create New Contract' is not selected in the renewal rule, it is possible to remove the renewal rule on item level.

To check the Renewal Rule settings.

  1. Go to the Business Configuration work center.
  2. Go to the Overview view.
  3. Search Renewal and Cancellation for Customer Contracts, Open it.
  4. Click Maintain renewal rules.
  5. Select one rule, You can see the detailed settings, for example, if the Create New Contraction option is selected.

Resolution

 This is currently the designed behavior of Contract Item Renewal.

Keywords

Renewal; Contract Item; Renewal Rule; 2005 new feature , KBA , AP-CCP-CC , Customer Contract , How To

Product

SAP Business ByDesign 2005 ; SAP Business ByDesign 2008