Symptom
You are not able to release a Customer Invoice due to one of the following errors:
- Conflict detected in item XXX of Project Invoice Request ID ABC; release not possible
- Conflict detected in item XXX of Service Confirmation ID ABC; release not possible
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Select invoice XYZ(XYZ represents the Invoice ID).
- Click on the Release button.
One of the following warning occurs and the invoice is not released:
- Conflict detected in item XXX of Project Invoice Request ID ABC; release not possible (XXX represents the line item number in the Project Invoice Request and ABC represents the ID of the Project Invoice Request).
- Conflict detected in item XXX of Service Confirmation ID ABC; release not possible (XXX represents the line item number in the Service Confirmation and ABC represents the ID of the Service Confirmation).
Cause
The Invoice is based on either a Project Invoice Request or a Service Confirmation which was cancelled after the Invoice was created.
Error A:
The Customer Invoice XYZ is based on the Project Invoice Request ABC and this Project Invoice Request was canceled after the Invoice XYZ was created and saved. Since the Project Invoice Request was canceled it is not allowed to release the Customer Invoice anymore.
You can check this as follows:
- Go to the Customer Invoicing work center.
- Select the Project Invoicing view.
- Select the Project Invoice Requests sub view.
- Show All Project Invoice Requests
- Select Project Invoice Requests ABC
You can see that the status is Canceled
Once the invoice request is canceled, we cannot revoke the cancellation.
Please Note: When you wish to cancel a Project Invoice Request you need to ensure that no Customer Invoice was created. In case a Customer Invoice was created you need to first cancel the Customer invoice before cancelling the Project Invoice Request.
Error B:
The Customer Invoice XYZ is based on the Serivice Confirmation ABC and this Service Confirmation was canceled after the Invoice XYZ was created and saved. Since the Service Confirmation was canceled it is not allowed to release the Customer Invoice anymore.
You can check this as follows:
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select Service Confirmation Invoice Request ABC.
You can see that the status is in status With Conflict - Click on the Check button.
- The following error is displayed:
Conflict in item XXX; cancellation requested but invoice already exists - Open the Service Confirmation.
- Navigate to the Service and Spare Parts tab.
- You can see that the Item XXX was cancelled via Reason for Rejection.
Resolution
You have to cancel the Customer Invoice XYZ.
See Also
2523260 - Revoke Project Invoice Request cancelation status
Keywords
Release; Invoice; Project Invoice Request; Status; Canceled; With Conflict; Check; Service Confirmation; , KBA , AP-CI-CI , Customer Invoice , Problem