Symptom
You want to add the facet 'Covered Objects' to the Contracts TI, however, when you open a contract in Adaptation mode, you see the facet marked as visible, but grayed out.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Contracts work centre.
- Go to the Contracts view.
- Open a Sales Contract.
- Click the user-icon in the top right.
- Click Start Adaptation.
On the Contract TI, you can see that the facet 'Covered Objects' will be grayed out, even if set as visible.
Cause
Covered Objects - only available for Service Contracts.
The SAP Cloud for Customer service contract allows you to maintain covered objects on item level.
Resolution
If the facet is marked as visible (and not hidden) via Adaptation mode, you will have it available on Service Contracts.
Open a Service Contract to see the facet.
See Also
Solution Guide for SAP Sales Cloud:
Keywords
Abgedeckte Objekte, Covered Objects, missing, gray, grey, facet, Adaptation, cannot add , KBA , LOD-LE-COP , Contract Processing , How To