Symptom
Disclaimer: Images/data in this KBA are from SAP internal systems, sample data or demo systems. Any resemblance to real data is purely coincidental
You have used a placeholder in your e-mail template text and see that it is not replacing with the desired value
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have created and maintained a template XYZ (XYZ is the name of the template) with text and placeholder #ContactName# (as an example)
Our example looks at Leads, but the same is true for other views, such as Ticket, Individual Customer, Contact, Account.
- Go to Leads workcenter
- Go to Activities view
- Navigate to the section Emails
- Select New
- Enter the recipient (Employee, Customer, Contact) in To
- From the e-mail editor, select the templates icon and choose the template XYZ
- Select Send
You expect that in the mail sent, the placeholder #ContactName# is replaced with the name of the recipient.
Cause
You have not mapped the placeholder value to its corresponding desired field and template can only be used when an e-mail is created from the chosen business object.
Resolution
- Go to Sales Workcenter
- Go to Templates view
- Select Show all and find for XYZ
- Open the template XYZ
- In the overview section, as shown below click on Add
- Maintain the value of placeholder name and map it to the fields exposed by lead which will replace the placeholder.
See Also
Keywords
Placeholder, template, missing, incorrect, sales, service , KBA , LOD-CRM-SC-TMP , Template , LOD-CRM-SRP , Service Request Processing , LOD-CRM-ACC , Account , Problem