Symptom
When a custom token for the standard field 'statusId' is used in an email, it resolves as a number.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Configure a custom token for the standard statusId field.
- Add the token to an email template and send an email using that template to a user or candidate.
- When the user or candidate receives the email it resolves as a number and not as a status label.
Cause
The Status ID (statusId) field is the unique identifier of the status name in a status set. This is the number that is showing when it was used as a custom token.
Resolution
This is currently considered expected behavior. To be able to use the Status Name field as a token in the future, please create an enhancement request.
See Also
2146038 - Custom Tokens - Recruiting Management
2090228 - How to Submit Ideas for SAP SuccessFactors Products
Keywords
Custom token, standard field, statusId, job application, Configure Custom Tokens , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem