SAP Knowledge Base Article - Public

2926863 - Error accessing service; Service Ping ERROR: Internal Server Error (500) While Performing Check Connection to Success Factors

Symptom

When you perform Check the connection for "Organisational Centre Replication Outbound with EC Service", system throws below errors

  • Checking connection failed
  • Ping failed
  • Error accessing service; Service Ping ERROR: Internal Server Error (500)

Environment

SAP Business Bydesign

Reproducing the Issue

1. Go to Application and User Management work center

2. Go to Communication Arrangement view

3. Search and Edit EC Integration

4. Check the connection for "Organisational Centre Replication Outbound with EC Service"

Cause

There are multiple causes which may result in above issue, below are known cases

Resolution

Case 1: Ping may fail but replication works fine

The SAP Web Service Framework offers a SOAP Ping to test a SOAP connection between service consumer and service provider. This SOAP ping is exposed in the soamanager UI and via API. The SOAP ping may fail, even when the SOAP communication works fine and web service requests are executed successfully.

Refer to the SAP Notes 1903596 - SOAP Ping fails with 3rd party service provider for more details

Case 2: Incorrect login credential of successfactor system is maintained in Business ByDesign system.

Steps to update communication arrangement credential:

1. Go to Application and User Management Work Center - Input and Output Management -  Communication Arrangement

2. Select communication scenario 'EC Integration'

3. Click Edit button

4. Go to 'Technical Data' Tab

5. Click 'Edit Advanced Setting' Button

6. Select one outbound communication scenario and click 'Edit Credential' button

7. Input username and password

8. Click ok button

9. Click Save and Reactivate button

10. Repeat the same steps from 6 to 9 for the second communication scenario as well

11. After above steps retest the employee replication scenario.

Case 3: The Communication Arrangement setup for 'EC Integration' relates to a wrong system. This might happen when you have several successfactor systems. The failed logon error message is occurring as the logon credentials for integration on BYD are not matching the SF logon credentials, i.e. they are maintained for company ID 'abc' instead of 'xyz' (where 'abc and 'cyz' represent company IDs). Please maintain the communication arrangement to correct the Company for both services. This is maintained via the following path (see also above steps for case 2):

1. Go to Application and User Management Work Center - Input and Output Management -  Communication Arrangement

2. Select communication scenario 'EC Integration'

3. Click on 'Edit API keys'

4. Select both services and maintain the correct company ID for integration

5. After performing above steps, retest the employee replication scenario.

See Also

List of SAP SuccessFactors API Servers

Keywords

Ping failed, Check connection, EC Integration. employee replication, service error, EC communication arrangement , KBA , AP-HMD-RPL , HCM-Master Data Replication , How To

Product

SAP Business ByDesign all versions