Symptom
When creating a curricula or viewing existing curricula, the custom columns are not displaying in the new UI. But these are visible in the old UI.
Environment
SuccessFactors HXM
SuccessFactors Learning
Reproducing the Issue
Using the Old UI, create a new curricula or open an existing one
Notice that the curriculum's custom column is shown and editable
Using the new UI, create or open an existing curricula
Notice that the curriculum's custom column is not being displayed
Cause
There are permissions that you need to add to the admin role in the new UI for the curriculum custom column to be displayed
Resolution
In the new UI Navigate to the following:
- System Administration
- Security
- Role Management
- Edit the Role of your admin
- Click on the Permissions Tab
- Click on "add one or more from list" link
- Add the following permission under System Administration section
- Edit Curriculum Custom Field
- View Curriculum Custom Field
Adding these two permission will allow you to view and edit the curriculum custom column fields.
Keywords
curriculum custom column missing, new admin ui, lms, curricula, custom column, missing, not editable, unable to edit custom column , KBA , LOD-SF-LMS-ADM , System Admin, Global Variables, References , How To