Symptom
Customer is replicating Contacts to C4C via "ManageContactIn" service interface and it is failing with the following error: "System expected a value for the type g".
On the Error Log, you can see the XPATH is pointing to FormattedNumberDescription.
<XPATH>soap:Envelope(1)soap:Body(2)n0:ContactBundleMaintainRequest_sync_V1(1)Contact(2)AddressInformation(9)Address(1)Phone(3)FormattedNumberDescription(1)</XPATH>
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator Work Center.
- Open the Web Service Message Monitoring View.
- Search for ManageContactIn Service Interface.
- Select the erroneous message.
- Click on the View button.
- Select the Error Log option.
Cause
The structure provided on the C4C inbound payload for <Phone> does not match the WSDL definition for ManageContactIn.
On the WSDL file the structure is as follow:
<Phone>String 321</Phone>
There is no field called<FormattedNumberDescription/> under Phone tag in the WSDL.
Resolution
In order to fix the issue, customer will need to adjust their scenario to send FormattedNumberDescription on a different node.
As a workaround, you can try to send it under <Telephone> node.
<Telephone>
<ObjectNodeSenderTechnicalID>Token 319</ObjectNodeSenderTechnicalID>
<FormattedNumberDescription>String 320</FormattedNumberDescription>
<MobilePhoneNumberIndicator>true</MobilePhoneNumberIndicator>
</Telephone>
Keywords
Contact, C4C, ManageContactIn, FormattedNumberDescription. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem