Symptom
- F4 help for timestamp does not show any data in the app 'Delete Financial Plan Data with timestamp'.
- There is a requirement to delete data based on timestamp using the app 'Delete Financial Plan Data with timestamp'.
Environment
- SAP S/4HANA Cloud
Reproducing the Issue
- Open the app 'Delete Financial Plan Data with timestamp'.
- Enter the timestamp which is to be deleted.
- The app displays many timestamps instead of just the one entered in the filter.
Cause
- To be able to delete data from a certain Planning Category, the "Delete allowed" Flag must be enabled for the same.
- The system will always display younger timestamps (if there are any), no matter how old the selected timestamp is (“very old” or not so old).
Resolution
To use this app, it is required to enable this app by selecting the 'Deleting Financial Plan Data' checkbox for each plan category from which plan data needs to be deleted.
Go to the 'Manage Your Solution' app under Configure Your Solution -> Finance -> General Settings -> Planning -> Maintain Category for Planning (SSCUI ID - 101970), choose Planning Category "PLN" and select checkbox "Deleting Financial Plan Data".
Also, in case the data needs to be deleted in the P-System, then configuration needs to be transported from Q to P first. Later, timestamps can be chosen for all file import involving Planning Category "PLN".
Note: In order to delete a particular timestamp data, roll back the system state and all other timestamps of runs that have been run afterwards.
See Also
For more infomation on the same, check the help portal link for Delete Financial Plan Data with Timestamp.
Keywords
Delete, Financial, Plan, Data, Planning, timestamp, F4 help, F4074, CO-OM-CCA-B, CO-OM, CO-FIO, S4_PC, S/4HANA Cloud. , KBA , CO-OM-CCA-B , Planning , CO-OM , Overhead Cost Controlling , CO-FIO , Fiori UI for Overhead Cost Controlling , Problem