SAP Knowledge Base Article - Public

2928719 - Arabic Language in Tickets

Symptom

Emails in Arabic Language have inconsistent behavior as of direction in the system.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Open Ticket ID 2814.
  4. Go to the Interactions tab.
  5. See that the direction of emails in Arabic language is not correct.

Cause

The system behaves differently in different parts of it:

  • In Tickets:
    • It shows correctly for Outbound Emails.
      • This happens because, for outbound emails, the object is created on the system and the system adds the direction to the <p> tag, that is handled by the application.
    • Shows incorrectly for Inbound Emails.
      • This happens because inbound emails, usually come with the direction on the <body> tag. This attribute on this tag is not handled by the application.
  • In the Email Activities:
    • Shows correctly on the Email Viewer.
      • The Email Viewer will show the email as it is in the vast majority of the cases.
    • Shows incorrectly on the Overview.
      • The Overview of the Email Activity will show only plain text. It cleans the HTML tags so the direction is not saved, as well as other attributes as bold or italics.

Resolution

To have the system considering the direction in all above scenarios (but the Overview of the Email Activity) you need to be logged on in Arabic.

Alternatively, you can propose a change on behavior to Product Management on the SAP Customer Influence Site.

Keywords

Arabic ; direction ; email ; flow ; rigth to left ; left to right ; RTL ; LTR , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To

Product

SAP Cloud for Customer core applications all versions