Symptom
- Error when refreshing reports based of Oracle.
- When refreshing a report based of Oracle in Crystal Reports, it fails with the error:
"Failed to load database information.
Details: The database connector: 'crdb_oracle.dll' could not be loaded.
The correct version of the database client for this database type might not be installed."
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- SAP Crystal Reports 2020
- Oracle 11g R2
- Oracle 12c
- Oracle 12c R2
- Oracle 18c
- Oracle 19c
- Oracle 21c
Reproducing the Issue
- In Crystal Reports, open a report based of Oracle.
- Refresh the report, and it the display the error:
"Failed to load database information.
Details: The database connector: 'crdb_oracle.dll' could not be loaded.
The correct version of the database client for this database type might not be installed."
Cause
- The Oracle Client is not installed or configured correctly on the computer where Crystal Reports is installed.
- For Crystal Reports 2013, 2016: It requires the 32bit Oracle Client.
- For Crystal Reports 2020: It requires the 64bit Oracle Client.
Resolution
- Install and configure the Oracle Client on the computer where Crystal Reports is installed:
- 1.1 Confirm which version of Oracle is supported for the version of Crystal Reports used, by reviewing the
supported platforms document available in the SAP Knowlege Base Article 2859510
- 1.2 Install the 32bit or 64bit Oracle Client on the computer based on the version of Crystal Reports installed, and the version of Oracle you are connecting to:
- For Crystal Reports 2013, 2016:
- Install the 32bit Oracle Client.
- For Crystal Reports 2020:
- Install the 64bit Oracle Client.
For examples:
- For Crystal Reports 2016, connecting to Oracle 12c, install and configure the 32bit Oracle 12c Client.
- For Crystal Reports 2020, connecting to Oracle 19c, install and configure the 64bit Oracle 19c Client.
- 1.3 Configure the Oracle Client to point to your Oracle data source.
Note:
For assistance in installing, and configuring the Oracle Client, contact your Oracle Database Administrator, or Oracle documentation.
- For Crystal Reports 2013, 2016: If the 32bit Oracle Client is installed and configured, and you are still receiving the error, then it's because you may have the 64bit Oracle Client instralled on the same computer. To ensure the 32bit Oracle Client is found, then:
- 2.1 Add the 32 bit path to the PATH environment variable right after the 64 bit path. For example:
PATH=C:\Ora12g64\product\11.2.0\client_1\bin;C:\Ora12g32\product\11.2.0\client_1\bin;C:\Windows\system32;...
- 2.2 Set the Oracle registry key: TNS_ADMIN, to point to the location of the tnsnames.ora
2.2.1 Start the Microsoft Windows Registry editor (regedit)
2.2.2 Navigate to the your Oracle 32bit client registry under:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE
2.3 Right click on your Oracle folder entry, and select in the contextual menu "New - String Value"
and create: TNS_ADMIN registry key with a value for the path to the 32 bit location of the tnsnames.ora on your hard drive.
Note: Do not add the key to Oracle_Home registry key for 64 bit.
Keywords
CR, ORA , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016 ; SAP Crystal Reports 2020