Symptom
You are unable to mass update the field Visit Duration for the account object. An error occurs. Error: External key, XXX does not exist.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Data Workbench work center
- Click on Import view
- Select Update
- Select Individual Object
- Search for Account
- Click on Next
- Upload file
- Click on Next until Import Data
- Go to Monitor view
- Select the relevant task name
Cause
The cause why the field Visit Duration could be that the field Owner_External_Key doesn't exist. This can be verified by exporting the object Employee and by filtering for the Employee ID.
Resolution
If your requirement is to update the visit duration and the owner is already maintained in the system, remove the field Owner_External_Key field from the template. Then it should update the field Visit Duration.
Keywords
mass update, visit duration field, external key, XXX does not exist, owner_external_key, , KBA , LOD-CRM-INT-DWB , Data Workbench , Problem