SAP Knowledge Base Article - Public

2930168 - Incorrect Sales Order Delivery Status in Customer Demand

Symptom

The Sales Order DEF (DEF represents the Sales Order ID) Delivery Status differs in Customer Demand ABC (ABC represents the Customer Demand ID).

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Search for Sales Order DEF.
  4. Open it.
  5. Go to the Items tab.
  6. In the Item for Product XXX (XXX represents the Product ID), the Delivery Status is In Process.
  7. Go to the Document Flow tab.
  8. Open the Customer Demand ABC.
  9. In the Item for Product XXX, the Delivery Status is Not Started.

Cause

The Delivery Status in the Customer Demand UI changes only when the actual delivery starts. Although both status are "Delivery Status", they are different status.

Resolution

System behavior is correct.

The Sales Order status changes to "In Process" when the Customer Demand is released. It is possible for a Customer Demand to be released even if it still has Delivery Status "Not Started", because the user context is different. 
One is for the sales user and the other is for the delivery user. For the sales user the delivery has already started because the delivery user acknowledged the delivery (released the Customer Demand). However, for the delivery user, it has not started yet, because the warehouse steps still have to be executed.

Both status are correct and are there for their respective users.

See Also

KBA 2882542 - How Status Changes in Sales Order with Material and Respective Back End Message Flow

Keywords

Sales Order, Customer Demand, Delivery Status, Delivery, Not Finished , KBA , AP-CR-CR , Customer Requirement , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions