Symptom
Upon initiating onboarding and completion of New Hire Data Review step, candidate logs in to the system but is unable to see the Personal Data Collection tile in his homepage. Thus, candidate is unable to complete his onboarding tasks.
Environment
SAP SuccessFactors Onboarding 2.0
Reproducing the Issue
- Initiate onboarding for a candidate either via RCM or API
- Complete New Hire Data Review.
- Welcome Letter is sent to the candidate.
- Login to the system as the candidate using the URL provided in the Welcome Letter.
- Personal Data Collection tile is missing in the home page.
Cause
Issue is caused by missing manager information in the candidate's Onboarding Process ID.
Resolution
There are two ways on how you can avoid encountering the issue:
- Ensure that manager information is present during initiate onboarding, or
- If Onboarding Process ID is already existing, go to Admin Center >> Manage Data, and edit the process Id to include the manager information.
(For detailed steps- 3405553 - [Onboarding] Candidates Manager is not displayed in New Hire Data Review when onboarding is initiated from RCM after 2H 2023 Release - SAP for Me )
See Also
Keywords
missing manager, onboarding process, Onboarding 2.0, Personal Data Collection tile missing, PDC missing in home page, onboarding process id, userBean , KBA , LOD-SF-OBX-HP , Home Page for Onboarding 2.0/ Tiles , Problem
SAP Knowledge Base Article - Public