Symptom
For Service Tickets in Cloud for Customer system, you are using the type-ahead function for e-mail addresses, where these are stored in the browser cache, making it easier to use recent e-mails in the system, however, you notice that some e-mail addresses disappear after some time.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Service work center.
- Navigate to Tickets work center view.
- Open any ticket.
- Navigate to Interactions tab.
- Click New to write a new e-mail.
- In the To field, start typing any e-mail address.
- See the system does not suggest that address anymore.
Cause
The Type Ahead Function for the e-mail addresses only store the latest 100 e-mail addresses in the browser cache. If more than 100 are present, the system deletes the least used address. If there are two addresses which have been used the same number of times, the oldest one that was added to the list is deleted, so that a new one can be included.
Also, the suggestions are stored in the browser cache against a user. So if the browser cache is cleared, or a different user signs into the system, the suggestions might not come up or be different. Note that the emails are stored in the browser, and no configuration in C4C is required.
Resolution
This is the standard behavior of the system.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
E-mail, Type Ahead Entry of E-mail Addresses, Missing, Cleared, Deleted, Browser, Cache, C4C, Service , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To