SAP Knowledge Base Article - Public

2931895 - Workflow Rule Fails With Reason Activation Occurs In The Past

Symptom

Scheduled ticket workflow rule is not triggered and you find Cancellation Reason Code: Activation Occurs in The Past.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Workflow Rules view.
  3. Find and select the affected scheduled workflow rule.
  4. Click More and select Rule Schedule.
  5. See the Status is Canceled and Cancellation Reason Code is Activation Occurs in The Past.

Cause

Activation Occurs in The Past means that at the point of time when conditions for the rule are sufficed, the current time is greater than the calculated Activation Time.

For example: you defined a rule to be executed 2 minutes after Created On. Current time is 12:00. Now, if the conditions suffice at 12:05, this time would be greater than the activation time [Created On + 2 Minutes = 12:02]. Such rules are marked as Canceled with the Cancellation Reason as Activation Occurs in The Past.

Resolution

This is an expected system behavior to cancel the schedule rule if activation occurs in past.

See Also

2867989 - Cancellation Reason Codes For Workflow

2583589 - How To Find Cancellation Reason Code For Scheduled Workflow

Keywords

workflow rule, cancelled, scheduled, ticket, activation time, not triggered, not working , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions