Symptom
You have your SAP Cloud for Customer integrated with SAP JAM and the queries you set up on JAM are not bringing results.
Environment
- SAP Cloud for Customer.
- SAP JAM
Reproducing the Issue
For this document, we'll use the example of a query for Tickets, but this applies to other objects as well.
- On your JAM system.
- Go to the Manage Service Tickets Filter section.
- Setup your filter, for example, to filter Ticket Type:
- ProcessingTypeCode eq 'XYZ' (XYZ represents the ID of the Ticket Type you want to filter).
- When you run the query, however, no results are found.
Cause
The OData Service used by SAP JAM is different form the usual OData Service on Cloud for Customer, so elements names and/or availability might be different.
Resolution
Please use the following link to access the OData Metadata and check the elemens you can use:
https://my123abc.crm.ondemand.com/sap/byd/odata/v1/c4c.svc/$metadata (123abc represents your tenant URL code).
See Also
Keywords
JAM ; C4C ; Cloud for Customer ; Odata ; Filter ; Elements ; Fields ; Odata explorer ; metadata ; collaboration ; , KBA , LOD-CRM-IN-JAM , JAM Integration with Cloud for Customer , How To