Symptom
You have created some custom fields in one of your extension BO, for eg. Sales Order and you want to extend these fields to the Post Goods Issue. You have created process extension sceanrio files in SDK and tried to extend however the fields are not appearing in the "Create Outbound Delivery and Post Goods Issue" screen.
Environment
SAP Business ByDesign
SAP Cloud Application Studio
Reproducing the Issue
- Extended the Sales Order BO with the custom fields in SDK.
- Created Process Extension Scenario files.
- Select the extension scenarios available in the Sales Order BO.
- Activate and check in the UI,Create Outbound Delivery and Post Goods Issue screen.
- The fields are not extended.
Cause
The reason why the fields are not appearing in PGI is because there is no extension scenario necessary for the Post Goods Issue as this is just a runtime document.
So once you save the PGI, Outbound Delivery is created. The resultant of PGI is an Outbound Delivery. So the extension field can anyway be extended to Outbound Delivery Screen. Once the Post Goods Issue is saved, it creates an outbound delivery. Hence, there is no extension scenario for "Create Outbound Delivery and Post Goods Issue". This is the reason why you are unable to see the field values in PGI.
Resolution
Currently only standard extension scenario supported from Sales Order are the following ->
From Sales Order - General > Outbound Delivery Request – General > Warehouse Request – General > Outbound Delivery – General > Outbound Delivery – Item
From Sales Order – Line Item > Outbound Delivery Request –Line Item > Outbound Delivery - Line Item.
Keywords
extending fields to PGI Post Goods Issue extension scenario outbound delivery to PGI extension fields are missing in PGI no process extemsion scenario for PGI , KBA , process extension scenario for pgi , extension fields in post goods issue , AP-RC-BDS-SI , ByDesign Studio Service Integration , AP-RC-BDS-EXT , ByDesign Studio Extensibility , Problem