SAP Knowledge Base Article - Public

2933230 - S/4HC: Issue with API BusinesspartnerSuiteBulkReplicateRequest while updating Business Partners

Symptom

Error Message R1 286: "Business Partner ******** already exists" when updating business partners through API BusinesspartnerSuiteBulkReplicateRequest.

Environment

SAP S/4HANA Cloud

Cause

Key Mapping does not exist for the Business Partner for which error is thrown.

If the Key Mapping does not exist for a Business Partners, the system assumes it is an insert scenario and API changes the task from Update (U) to Insert (I). Since, the Business Partner already exists for with that number in the system, the replication fails with the error message BP already exists.

Resolution

While sending XML Payload with an update scenario, ensure Key Mapping exists for all the Business Partners mentioned in the payload.

To check and add Key Mapping follow the below steps:

  1. Open App Manage Key Mappings.
  2. Select Object ID Type as Business Partner Number.
  3. Enter the Business Partner number without leading zeroes.
  4. Mapped Objects would be listed.
  5. If the Key Mapping does not exist, click on Add Row to maintain the mapping. 

Keywords

S4_PC, communication, user, role, authorization, partner, CVI, customer, supplier, replicate, replication, client, SAP_COM_CSR_0008, SAP_COM_0008,  BusinessPartnerSUITEBulkReplicateRequest_In, R1, 286, R1286, authorisation , KBA , LO-MD-BP , Business Partners , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions