SAP Knowledge Base Article - Public

2933437 - Unable to generate Work Order Event in Intelligent Services Center (ISC) - Employee Central

Symptom

A new work order is created, but the event is not published in Intelligent Services Center (ISC).

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP HXM SucessFactors
  • Employee Central Intelligent Services Center
  • Employee Central Contigent Workforce Management

Reproducing the Issue

  1. Create a new work order via Take Action > New Work Order or via Add Contingent Worker;
  2. Go to Admin Center > Intelligent Services Center;
  3. See that no event record was published under New Work Order.

Cause

There is no business rule to trigger the creation of an event assigned to New Work Order object.

Resolution

  1. Create a new rule under Basic scenario (if not existent yet);
  2. Set "Work Order" as base object;
  3. Define the IF conditions as desired;
  4. In the THEN conditions, use: Execute and Trigger New Work Order Event(). 
  5. Go to Configure Object Definitions > Work Order.
  6. Assign this rule under Post Save rules.

See Also

Defining and Assigning Business Rules to trigger Intelligent Service Event section of Setting Up Intelligent Services Guide.

Keywords

event, isc, intelligent services, new work order, rule , KBA , LOD-SF-EC-ITS , Intelligent Services (EC Components Only) , LOD-SF-EC-CWF , Contingent Workforce , Problem

Product

SAP SuccessFactors HCM Core all versions

Attachments

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