Symptom
A new work order is created, but the event is not published in Intelligent Services Center (ISC).
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP HXM SucessFactors
- Employee Central Intelligent Services Center
- Employee Central Contigent Workforce Management
Reproducing the Issue
- Create a new work order via Take Action > New Work Order or via Add Contingent Worker;
- Go to Admin Center > Intelligent Services Center;
- See that no event record was published under New Work Order.
Cause
There is no business rule to trigger the creation of an event assigned to New Work Order object.
Resolution
- Create a new rule under Basic scenario (if not existent yet);
- Set "Work Order" as base object;
- Define the IF conditions as desired;
- In the THEN conditions, use: Execute and Trigger New Work Order Event().
- Go to Configure Object Definitions > Work Order.
- Assign this rule under Post Save rules.
See Also
Defining and Assigning Business Rules to trigger Intelligent Service Event section of Setting Up Intelligent Services Guide.
Keywords
event, isc, intelligent services, new work order, rule , KBA , LOD-SF-EC-ITS , Intelligent Services (EC Components Only) , LOD-SF-EC-CWF , Contingent Workforce , Problem
Product
Attachments
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