SAP Knowledge Base Article - Public

2933437 - Unable to generate Work Order Event in Intelligent Services Center (ISC)

Symptom

A new work order is created, but the event is not published in Intelligent Services Center (ISC).

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central - Intelligent Services Center

Reproducing the Issue

  1. Log into instances.
  2. Navigate to employee profile of test user.
  3. Either edit the work order or create a new work order via Take Action -> New Work Order or via Add Contingent Worker.
  4. Go to Admin Center -> Intelligent Services Center -> Event -> New Work Order.
  5. See that no event record was published under New Work Order.

Cause

Absence of Business Rule for Event Creation in New Work Order Object.

Resolution

  1. Navigate to Configure Business Rule.
  2. Create a new rule under Rules for MDF Based Objects.
  3. Set "Work Order" as base object and "Validate" as purpose.
  4. Define the IF conditions as desired.
  5. In the THEN conditions, use: Execute and Trigger New Work Order Event (). 
  6. Go to Configure Object Definitions -> Work Order.
  7. Assign this rule under Post Save rules.

           

See Also

Defining and Assigning Business Rules to trigger Intelligent Service Event

Keywords

event, ISC, intelligent services, new work order, rule, work order object, event monitoring, Rules for MDF Based Objects, configure business rule , KBA , LOD-SF-EC-ITS , Intelligent Services (EC Components Only) , LOD-SF-EC-CWF , Contingent Workforce , Problem

Product

SAP SuccessFactors Employee Central 2411

Attachments

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