SAP Knowledge Base Article - Public

2934107 - Avalara Error in Supplier Invoice or Purchase Order

Symptom

You are getting the error 'Avalara Error:' in supplier invoice or Purchase order.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Supplier invoicing work center.
  2. Go to Invoices and credit memos view. 
  3. Search for respective Invoice. 
  4. Click Check button. 
  5. You will get the error.
  6. Click View All.
  7. Go to Items tab.
  8. Go to Parties and Locations sub tab.
  9. Ship-From Address has only country appearing currently and Postal Code is empty (also other details of address are also empty).

Note: You can follow similar steps for purchase order->item tab->delivery tab.

Cause

In Supplier Master Data you have not maintained the Postal Code.

The Address in general is incomplete without Postal Code or region or Jurisdiction Codes.

or

Wrong Postal Code is maintained.

Resolution

Maintain the details in Supplier Master Date and the issue will not occur for new invoices.

For existing effected invoices, follow below steps:

  1. Go to Supplier Invoicing work center. 
  2. Go to Invoices and Credit Memos view. 
  3. Search for respective Invoice. 
  4. Remove the Supplier.
  5. Click check button.
  6. Again add the same Supplier.
  7. Click check button again.
  8. You will not see this error.

 Note: Ensure that Postal Code entered is correct by verifying it in Google.

Keywords

Avarala Error; Vertex; Zip Code; Postal code; Region , KBA , SRD-SRM-PRO , Purchase Requests and Orders , AP-SIP , Supplier Invoice Processing , Problem

Product

SAP Business ByDesign all versions