Symptom
You noticed that the business partner created for a company will sometimes have the same ID as the original org unit, but in some cases will have a unique ID taken from the business partner internal number range.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Organizational Management work center.
- Access the Org Structures work center view.
- Click on New.
- Enter org ID.
- Click on Save.
- Click on Edit.
- Mark it as Company.
- Go to the Business Partner work center.
- Access the Business Partners view.
Cause
A possible cause is that the org ID lies in the external number range and for this reason it is taken over. In another case the org ID doesn't lie in the external number range and for this reason the internal number range is taken over. It depends on the total length in the Business Configuration activity General Business Partners > Define Number Ranges for Business Partners. For example, an org ID with 10 or less than 10 characters is taken over as a Business Partner ID, but an org ID with more than 10 charatcers is not taken over.
It might also be the case that a business partner already existed with an ID that was identical to the ID of the org unit set as a company. In this case, since the business partner existed first and is not associated to the org unit, the system has to give a new ID to the business partner created for the company.
Resolution
This is the intended system behavior.
See Also
Keywords
external number range, internal number range, business partner creation, org unit, associated business partners, , KBA , LOD-LE-BP-BP , Business Partner , LOD-LE-OM-OM , Org. Management , Problem