Symptom
You want to filter according to a certain Basic Search field, but it is not working.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers Work Center.
- Go to the Accounts View
- Start Adaptation mode.
- Select the OWL.
- Click Add.
- Select the option Basic Search Fields.
- Add e.g. the field Tax Number to the Basic Search.
- In the Basic Search box, filter for a valid Tax number that exists in an Account's facet Tax Numbers.
Result: The system does not display any results even though an Account with the same tax number exists.
Cause
The field in question is a "Read Access Logging" (RAL) field.
Resolution
RAL enabled fields are not supported for basic search. This is true for all standard fields as well as for extension fields. Currently, the add/modify Basic Search pop-ups list RAL enabled field(s) which is/are available to add to the Basic Search. If you add those fields from the list, the basic search on these fields will not work.
In one of the upcoming releases these fields will be removed from the list of available fields to be added to the Basic Search.
Keywords
extension field; KUT field; RAL; Read Access Logging; basic search; advanced search; , KBA , AP-RC-UIF , C4C UI Framework , Problem