Symptom
- Live HANA connection with SAML SSO enabled with Azure AD as Identity Provider (IdP) suddenly stops working with the following error in SAP Analytics Cloud (SAC):
- "https://yourservername/sap/hana/xs/saml/login.xscfunc" cannot be reached. yourservername’s server IP address could not be found.
- The SAP HANA server is also using same Identity Provider (IdP)
- The SAP HANA server is exposed to internet users via a reverse proxy
Environment
- SAP Analytics Cloud (Enterprise) 2020.8.9
Reproducing the Issue
- Log on to SAC tenant with SAML SSO enabled with Azure AD as IdP.
- Open one story based on Live Data connection with SAML SSO as Authentication type.
=> The SAP HANA server is also using same Identity Provider (IdP).
=> The SAP HANA server is exposed to internet users via a reverse proxy. - The following error suddenly occur while it has been working for a long period.
=> "https://yourservername/sap/hana/xs/saml/login.xscfunc" cannot be reached. yourservername’s server IP address could not be found.
Cause
- According to help guide, if your SAP HANA server is exposed to internet users via a reverse proxy, in your SAML identity provider configuration, ensure that the Assertion Consumer Service (ACS) endpoint URL for the SAP HANA service provider is set to the SAP HANA server's reverse proxy URL. For example, https://<reverse-proxy-host>/sap/hana/xs/saml/login.xscfunc.
- However, in Azure AD, it was changed to have two URLs for Assertion Consumer Service (ACS) endpoint: one is correct with SAP Hana URL and marked default; another url is YOURSERVERNAME.
Resolution
- Delete URL- YOURSERVERNAME - for Assertion Consumer Service (ACS) endpoint of SAP HANA service provider in your SAML identity provider configuration.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped, SAML, SSO, Azure, IdP, Assertion Consumer Service, acs, endpoint , YOURSERVERNAME, reverse proxy, , KBA , LOD-ANA-AUT , SAC Authentication / Login , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem