SAP Knowledge Base Article - Public

2935260 - Mandatory Property of Tasks and Surveys Assigned via Routing Rules is not Considered in Leads

Symptom

You see that the tasks and surveys which are marked as mandatory are not considered during the lead lifecycle

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite:

  • Create Survey in the Surveys work center from Surveys view.
  • Create Activity Plan in the Activity Planner work center from the Plans view (ensure that you have enabled Mandatory flag)
  • From Activity Planner work center in the Routing Rules view, create an Activity Routing Rule for Business Application: Leads
  1. Go to the Sales Work Center
  2. Go to Leads view.
  3. Select New and create a Lead that fulfills the conditions defined in the Routing Rule. 
  4. Save and Open the Lead.
  5. Navigate to the Activities facet to see the task
  6. Navigate to Surveys facet to see if the survey

Once the surveys/ tasks are added, you see that the mandatory property is not considered and system allows you to qualify and convert the lead, despite of not completing the mandatory task, survey.

Cause

This feature is not supported in the current release of SAP Cloud for Customer

Resolution

1.  If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder

2.  If you are a customer:

    1. Contact your Account Executive
    2. Check the link https://www.sap.com/uk/services/advisory-development/application-development.html#contact-us

An alternative option may be to check the SAP Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer

See Also

Activity Planning and Routing 

2263540 - Mandatory Tasks and Surveys Assigned to Account but not Applied in Visits

2586331 - Auto Assign Functionality Of Surveys In Sales Documents

 2578904 - Survey is not auto assigned to Lead from Activity Planner

2384893 - Lead and Opportunity surveys are not automatically assigned

Keywords

Survey, Task, Routing Rule, Activity planner, Mandatory , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-ACT-ROT , Activity Routing , LOD-LE-SUR-DEF , Survey definition = design time , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions