Symptom
Survey initially created in a different language is not available in Transport Management.
Environment
SAP Cloud for Customer
Reproducing the Issue
For demonstration purposes, I will describe an example scenario.
Prerequisite: You have created 6 surveys in total, 5 of which were originally created with language English, while 1 was created with language German. Your expectation is all 6 will be available in the transport object.
Steps:
- Log into the tenant in German Language.
- Go to the surveys work centre.
- Observe there are 6 surveys in total.
- Go to Transport Management work centre.
- Create a new Transport Request.
- Add Transport Objects.
- Select Surveys and use the OVS to view all surveys available for transport.
- Observe only 1 survey is available for selection, and you had expected 6.
Cause
Surveys which do not match the logon language of the user currently logged in, will not be available for selection in the transport object.
Resolution
Only the surveys matching the logon language of the user is displayed in the Transport Object.
In other words, if you have a survey which was created with language English and you logged in with language German, it won't be available for selection in the Transport Object.
This is the expected system behavior and is designed to reduce the possibility of language related inconsistencies with Transport Objects.
See Also
2692719 - Language Translation In Surveys
Keywords
Transport Management, Survey, Language, Transport Object, Login language, not available in transport object , KBA , LOD-LE-UTM , Unified Transport Management , Problem