Symptom
You added an emoji copied from any other tool to the Ticket Description. When you try to search on the tickets list search field or the columns filter or on the Advanced Search you have no result.
Environment
SAP Cloud for Customer.
Reproducing the Issue
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Go to Service > Tickets.
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Create a new ticket.
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On description field, add an emoji.
- Now on Tickets list view, try to search for this emoji.
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You have no result.
Cause
Ticket description is basically Rich text editor enabled and hence such texts are also possible. It's not allowed in all the descriptions. You can try out for other documents like account or sales quote.
Resolution
It's not possible to search for it as well as our backend infrastructure doesn't support that.
Keywords
Emoji, Search, Filter. , KBA , AP-RC-UIF , C4C UI Framework , How To