Symptom
Upon saving the tax data in account for country/region Canada, you see an error
Error: Federal Business Number is invalid
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customers Workcenter
- Go to Accounts view
- Select show all and find for account ABC (ABC represents the name of the account)
- Open the account ABC
- Go to facet Tax Numbers
- Select Add
- Enter Tax country as CA - Canada and Tax Number Type as Federal Business Number
- Input the 9 digit Tax Number value and select Add
Upon save, you will see the afore mentioned error and this behavior is also applicable when you replicate a business partner with similar data
Cause
In SAP Cloud for Customer, the tax number check, checks for Canadian federal business numbers if they fulfill the Luhn condition.
In case if it does not meet the criteria defined the afore mentioned error will be displayed.
For more details on Luhn condition, please check https://en.wikipedia.org/wiki/Luhn_algorithm
Resolution
This is the expected behavior in the current version and is in line with the product design, which has further been derived from practices recommended by the regulatory authorities.
1. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
2. If you are a customer:
- Contact your Account Executive
Check the link https://www.sap.com/uk/services/advisory-development/application-development.html#contact-us
An alternative option may be to check the SAP Cloud for Customer Ideas Forum to submit an idea: https://influence.sap.com/SAPCloudforCustomer
See Also
Keywords
Registration Number, Federal, Tax number Type, Account, Tax data, Invalid, Error, Canada , KBA , LOD-CRM-ACC , Account , Known Error