Symptom
The Invoice Date of the Sales Order Invoice Request or Customer Contract Invoice Request for a Service of Item Type fixed price without actuals and/or fixed price is not the expected one.
And also in the Sales Order, the Invoice Date in the Items tab for a Service of Item Type fixed price without actuals and/or fixed price is not the expected one.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Open Sales Order XYZ (XYZ represents the Sales Order ID).
- Navigate to the Items tab.
- Select the respective line item of the Service with the Item Type fixed price without actuals or fixed price.
- In the Details tab under the Service section you can see that the Invoice Date was determined automatically by the system.
The Date is not the expected Date.
The following also applies to Contracts. We will use a Sales Order as an example.
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select the Sales Order Invoice Request XYZ.
The Invoice Date for the Sales Order Invoice Request is not the expected one.
Cause
The Invoice Date of the Sales Order Invoice Request or for a Customer Contract Invoice Request for a Service (fixed price without actuals and/or fixed price) is automatically determined from the creation Date of the Sales Order of Contract.
Also the Invoice Date in the Sales Order for a Service (fixed price without actuals and/or fixed price) in the Items tab in the Sales Order is automatically determined from the creation Date of the Sales Order.
Resolution
If you do not which that the Invoice Date is the same as the creation Date of the Sales Order or Contract you can manually change this to the required Date via the Invoice - Advance button during invoicing.
For Sales Orders you can alternatively also change the Invoice Date manually in the Sales Order Items tab to the required Date. This will then also update the Sales Order Invoice Request and during invoicing of the Sales Order Invoice Request the changed Invoice Date will be taken into consideration for the creation of the Invoice.
For Contracts it is not possible to maintain an Invoice Date for the Item in the Items tab. Alternatively you can create the Item with an Invoice Schedule in which you can enter the respective Date.
Keywords
Invoice Date; Sales Order; Sales Order Invoice Request; Invoice Requests; Contract; Contract Invoice Request; , KBA , SRD-CRM-ORD , Orders & Contracts , AP-SLO , Sales Order Processing , Problem