Symptom
When selecting Reply via E-mail button at the top of Interactions screen, To and From fields are empty.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: ticket with e-mail and portal interaction exists in the system.
- Go to the Service work centre.
- Go to the Tickets view.
- Open ticket ABC (ABC represents affected ticket ID).
- Go to the Interactions tab.
- Select Reply via E-mail button at the top of the screen.
- Notice To and From are empty.
- Select More (...) button for specific e-mail interaction.
- Notice To and From are populated.
Cause
The last interaction in the ticket is a portal interaction.
Resolution
The reply option on top and in selected interaction are functionally different.
- Reply to customer (on top) - this is reply to the latest inbound interaction. The response channel gets selected based on the latest interaction type. If the latest interaction is portal note, the content in the e-mail To/From are not filled. This is filled if latest inbound interaction is e-mail.
- Reply/Reply All for selected e-mail - this is reply to the selected interaction. As the selected interaction is e-mail, the To/From is filled from the content.
Keywords
e-mail, reply, to, from, reply all, interaction, portal note, internal memo, empty, not filled, e-mail address, internal memo , KBA , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions