Symptom
Last visit date is not correctly set when you perform check out for visit created in the past.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to the Visits work center.
2. Go to the Visits view.
3. Create a Visit with a Visit date in the past.
4. Perform check in/ check out.
5. Create a second Visit for the same account of the first created.
6. Maintain the Visit date in the past.
7. Perform check in/ check out.
8. Open the account that refers to the Visits.
9. Go to the Visits facet.
10. The field "Last Visit Date" must show the End Date/Time from the last visit.
Cause
For past Visit the system assumes that the visit occurred on the date maintained at the creation of the object.
For future Visit, it is required to reschedule the date to the current day.
Resolution
This is expected for the system behavior.
Keywords
Visit Date, Last Visit Date , KBA , LOD-CRM-ACT-VST , Visit Planning , How To