Symptom
While performing the migration for the object 'Customer' below error occurs;
"Industry xxxx for object Business Partner with ID xxxxxxxx could not be assigned"
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open "Migrate your Data" App.
- Go to the relevant migration project.
- Select the Migration object "Customer".
- Upload the migration template and then click on Activate.
- Click on Start transfer.
- Perform the Validation phase followed by the Convert Values phase.
- Then Simulation phase.
Cause
Industry Mapping is not maintained in the system.
Resolution
Maintain the mapping/assignment via the SSCUI 102897 - Assign Industries.
To access the SSCUI, please perform the following steps:
- Open App "Manage your solution".
- Click on "Configure your solution".
- Filter Application area = "Database and Data Management " and Sub application area = "Business Partner " or you can also search for SSCUI '102897'.
- Click on configure button available next to the SSCUI.
Make sure that the following customizing is maintained in the system.
- Maintain Industry Systems and Industries (SSCUI ID: 102850) - To create and maintain Industry systems and Industry keys for BP.
- Define Industries (SSCUI ID: 102851) – To create Industry keys for Customer/Supplier
- Assign Industries (SSCUI ID: 102897) – To assign/map BP Industry to Customer/Supplier Industry keys.
Keywords
CVI_MAPPING00, Industry, Migration, CA-GTF-MIG, S4_PC, SAP S/4HANA Cloud Public Edition, Industry, object, Business, Partner, with, ID, could, not, be, assigned. , KBA , CA-GTF-MIG , SAP S/4HANA Data Migration Cockpit Content , LO-MD-BP , Business Partners , Problem