SAP Knowledge Base Article - Public

2936954 - System Dump While Changing the Time Model from X to Y for Employee ABC

Symptom

When changing an employee's Time Model from X to Y, the system throws a dump (X and Y represent time models)

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Time Administration work center.
  2. Select Time Sheet View.
  3. Open Time File of an Employee.
  4. Go to Time Profile facet.
  5. Change the Time Model from X to Y.

System throws dump

ST22 Log:

1 CX_SY_ITAB_DUPLICATE_KEY, Program:CL_ESF_ALV_DP_CACHE===========CP, Include:CL_ESF_ALV_DP_CA
2 Info: A row was to be added that would have lead to a duplicate of the NODE_ID key.

Cause

There are two possible causes:

Cause 1

One of the Statistical Account assigned to this Employee has minimum balance is Negative (Eg: - 20)

Cause 2

For the Time Account, in the details section in Business Configuration, you have maintained a "Fixed Limit", but no Minimum Balance.

Resolution

To resolve the issue, you can either set the Fixed Limit in the Check limit to No Limit or ensure a valid Minimum balance is maintained.

Keywords

Fixed Limit, minimum balance, negative balance, time account , KBA , SRD-HR-TLM , Time and Labour Management , Problem

Product

SAP Business ByDesign all versions