Symptom
Email cannot be sent from a specific Business Object such as Lead.
Environment
SAP Cloud for Customer
Reproducing the Issue
- We take the Lead business object as an example here.
- Go to Lead work center and open the lead 123 (123 represents the lead ID).
- Go to Activities tab.
- Click on New button to send email, add an recepient with valid email address , and maintain some text in the email body.
- Click on Send button >> The sending email screen disappears but nothing happens. The email activity does not exist in the Activities tab, the recipient did not receive the email.
Cause
There's a Code List Restriction existing for Activity business object, and 'Party Role' is restricted for Recipient role.
Resolution
The Reciepent relevant party roles should be allowed in the code list restriction.
Keywords
send email, Lead, 发送邮件 , KBA , LOD-LE-AM , Activity Management , Problem
Product
SAP Cloud for Customer core applications all versions