SAP Knowledge Base Article - Public

2938249 - Employee Central - Time Off Recalculation

Symptom

This is a collection of useful articles related to Time Off Recalculation.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HXM Suite

Resolution

FAQ Index:

Other Recalculation Topics:

 

Q. How does Recalculation work?

A. KBA 2813499 - How does the recalculation work in Time Off

Q. What triggers a recalculation?

A. To recalculate accruals as described in the recalculation Guide, you need to switch on the recalculation feature on the Time Management Configuration object. If you don't do this, accruals can still be recalculated, but as described in the Accrual Management In Time Off documentation in the Implementing Employee Central Time off guide.

Changes to the following Time Information within an employee's Job Information trigger recalculation in Time Management:
● Work Schedule (standard or individual)
● Time Profile
● Holiday Calendar
● Time Recording Profile
● Default Overtime Compensation Variant

Note: Changes within these objects do not automatically trigger a calculation. For example, if you change which holiday calendar is assigned to an employee, this triggers a recalculation. However, if you simply make a change to the holiday calendar itself - say, by adding another holiday or removing one already there - no recalculation takes place.

Changes to the following Time Management data can also a trigger recalculation:
Absence data in Time Off
● Temporary time data

Q. How to View Time Management Recalculation Results from the Execution Manager Dashboard

A. You can use the Execution Manager to view failed recalculation runs.

Recalculation events are processed by default as Time Management evant-based tasks.

You can access the Execution Manager from the Admin Center by choosing Execution Manager Dashboard. In Execution Manager Dashboard you need to choose Middleware Integrations.

Alerts are created for erroneous recalculations. You can see the alerts in the Admin Alerts 2.0 UI. Please process the alerts regularly so that the recalculation can be executed in a timely manner to update the absences, time sheets, and accruals according to the changes that triggered the recalculation.

In addition you can use the Execution Manager to view information on recalculation jobs that have already run and have taken up mainly recalculation events in status Error again.

Please see the Guide for more details on viewing Recalculation Results

Q. Why was a recalculation not triggered?

A 1. Accruals are not Recalculated

Checks:

  • Is Recalculation enabled via the Time Management Configuration Object in Manage Data UI?
  • Is there an original accrual posting on the users time account which was created by the system for the system to recalculate? If not - there is no "posting" to recalculate. Solution: Run the accrual calendar for the time account type to create the missing Accrual postings.
  • Make sure the accrual is not just a "simulated" accrual, and you can see an accrual under Time Account Detail Postings. If it is just a simulation (Simulation set = Yes on time account type)  Solution: Run the accrual calendar for the time account type to create the missing Accrual postings.
  • Is the field / data you updated to trigger a recalculation defined in the accrual / hire / termination rule (depends which accrual period the user is in)? If not, there may be no relevance for a recalculation.
  • If issue is that recalculation is not happening automatically, but is reflected during simulation or creation of TMRE, please check in your accrual rule if you are using the "Key Date" rule functions. This ensures the system pulls the value of the job info field on the latest job info record, and not the value valid on Accruable start date. KBA2557428 - Changing a Users Job Information Field Does not Trigger a Recalculation

See Guide: Job Information Rule Functions

  • Get Job Info Date Field Value On Key Date()
  • Get Job Info Numeric Field Value On Key Date()
  • Get Job Info String Field Value On Key Date()

Other information needed if you create a support case regarding why a recalculation was not triggered:

  • User example, Time Account Type name, what the current accrual posting amount is, what you expect the recalculation amount to be, and the reasoning behind the need for recalculation.
  • If you navigate to the Time Account Process Simulator tool, is the result the recalculated value or is it also not being recalculated here? Please create a rule trace for the simulation if creating a support case. 

See related KBAs:

  • 2637267 - How to Enable/ Disable Recalculation in Time Off
  • 2444562 - Time account balances not recomputed after triggering recalculation
  • 2557428 - Changing a Users Job Information Field Does not Trigger a Recalculation
  • 2459749 - Recalculation is not Triggered on change of Recalculation Field
  • 2564183 - Recalculation of LOA Resetting Incorrectly When updating Actual Return Date.

A 2. Absences are not Recalculated / Absence Change does not Trigger a Recalculation

Checks:

  • Is Recalculation enabled via the Time Management Configuration Object in Manage Data UI?

See KBA: 2637267 - How to Enable/ Disable Recalculation in Time Off

  • If an absence change does not trigger an accrual recalculation as you expected > Check the Time Type of the absence >  "Accrual Recalculation Relevance" Field> If that field is set to Full, it then looks at the related time account type to determine which settings should trigger a recalculation. 
  • Is Flexible requesting enabled on the Time Type? If so no recalculation will occur (See below KBA)
  • Was there a change made to existing holiday calendar? If so, this requires a manual trigger of recalculation using a Time Management Recalculation event (described in below KBAs).

See KBA's: 

  • 2803657 - Recalculation of Absences is not Working
  • 2328948 - Time Off: How to recalculate leave balances when Holiday Calendar is updated

Other Useful KBAs on this topic:

  • 2738339 - Recalculate Time Account Balances Based on Employee Time Changes
  • 2564183 - Recalculation of LOA Resetting Incorrectly When updating Actual Return Date

Q. Why was a recalculation was triggered?

A. Review the following:

  • Check the date of the recalculation posting on the time accounts tab on users workbench. Note that changes to different Time Accounts can trigger recalculation for the user. i.e: Created a record for Time Account B and this triggered a Recalculation on Time Account A.
  • On this date, was there a job information change? Was there an absence created/changed?
  • Either of the above changes can trigger a recalculation - see section in this KBA: "Q. What triggers a recalculation?"
  • Changes within time off configuration may not cause automatic recalculation, for example updating the accrual rule or editing recalculation fields on the time account type. However, a change to job information/absence data at a later point can trigger this recalculation.

 Q. In Which Order Is Recalculation Performed?

A. The order of recalculation processes is always fixed and is as follows:

1. Recalculation of existing absences is performed in Time Off.
2. All affected time sheets are recalculated (assuming that Time Sheet has been activated in the system).
3. Transfer dates are recalculated and adjusted based on the Effect on Transfer Date rule.
4. Accruals are recalculated and adjusted accordingly.

 Other Recalculation Topics

Recalculation job is failing

  • For Partner or support: Check job failure details in Provisioning from Monitor Jobs, and search for results using x-search, JIRA etc.
  • Customer: Create a support case

Possible causes:

  • 2653357 - Trigger Recalculation Job failed
  • 2572279 - Recalculation of Accruals and Absences is not Working

Future Recalculation

  • 2408202 - Scenario for recalculation of the future dated requests
  • 2642362 - Recalculation for Future Time Accounts

Recalculation Notifications

  • 2488194 - Changes to Time Information Fields in Job Information Trigger Recalculation Notifications to the User Making the Changes

Support: See internal memo

See Also

2637267 - How to Enable/ Disable Recalculation in Time Off
2813499 - How does the recalculation work in Time Off
2557428 - Changing a Users Job Information Field Does not Trigger a Recalculation
2444562 - Time account balances not recomputed after triggering recalculation
2557428 - Changing a Users Job Information Field Does not Trigger a Recalculation
2459749 - Recalculation is not Triggered on change of Recalculation Field
2803657 - Recalculation of Absences is not Working
2328948 - Time Off: How to recalculate leave balances when Holiday Calendar is updated
2738339 - Recalculate Time Account Balances Based on Employee Time Changes
2564183 - Recalculation of LOA Resetting Incorrectly When updating Actual Return Date
2653357 - Trigger Recalculation Job failed
2572279 - Recalculation of Accruals and Absences is not Working
2408202 - Scenario for recalculation of the future dated requests
2642362 - Recalculation for Future Time Accounts
2488194 - Changes to Time Information Fields in Job Information Trigger Recalculation Notifications to the User Making the Changes

Keywords

Recalculation is not triggered, why did the system recalculation, recalculation failing, recalculation is not working, why was there a recalculation, FAQ , KBA , LOD-SF-EC-TIM-REC , Recalculation , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions