Symptom
When you preview a Customer Invoice , you can see that the form template picked up by the system is not the expected one. You have defined a customized Form Template and have defined a rule for this template in which you maintained the Seller /Invoicing Unit as XYZ. Since your invoice has the Seller XYZ , you expect the customized form template get picked.
(XYZ presents the ID of the organization in the customer invoice.)
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Go to the Invoice Documents view.
- Search for Invoice YYY and select it.(YYY is the ID of the Customer Invoice)
- Click on Preview Button
- You can see that the Form Template ABC is selected instead of Template DEF(ABC and DEF are the Form Templates defined in the system for Customer Invoice)
Cause
In the rule for the template you have maintained the Seller /Invoicing Unit as XYZ, this means when Seller and Invoicing Unit are both XYZ, the template will be picked. While, in invoice YYY, only seller is XYZ, Invoicing Unit is not XYZ or Vice versa.
You can check the form rules by following below steps:
- Go to the Application & User Management work center
- Go to the Input & Output Management view.
- Go to the Form Template Selection subview.
- Select the form template for the Customer Invoice.
- Open the form template DEF.
Resolution
You can change the invoicing unit in the customer invoice as per the rule maintained in the form template.
Steps for changing the invoicing unit in the customer invoice:
- Go to the Customer Invoicing work center.
- Go to the Invoice Documents view.
- Show All Documents and Find YYY (YYY represents the invoice ID).
- Edit the invoice and select View All button.
- Select the Involved Parties tab.
- Change the invoicing unit to unit that is maintained in the form template rule.
- Save the invoice.
See Also
Keywords
Incorrect Form Template ; Customer Invoice form template; , KBA , customer invoice form template , customer invoice , AP-CI-CI , Customer Invoice , Problem