Symptom
You would like to perform the Ticket assignment based on the starting letters of a specific field (e.g for Customers). However, when selecting the field Customer and the condition Starts With you have noticed that this is a value selector field and not a free text field.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Select the Service & Social view.
- Click on Ticket Routing Rules by Organization or Territory.
- Select any field (e.g Customer) and the condition Starts With.
Cause
The condition Starts With matches any beginning of a string/ID of a Customer. In this case no wildcards (asterisk) * should be added.
It is important to remember if an asterisk * is directly added, it will be considered as a string literal i.e it will make a direct comparison on * instead of considering the * as All.
Resolution
Select the field (e.g Customer ID) without using the wildcard *, this will result in the system starting the assignment considering the initial letters of that selected field.
Keywords
Routing Rule; Letters; Not Working; Alphabetical; Order; Sequence; , KBA , LOD-CRM-SRP , Service Request Processing , How To