SAP Knowledge Base Article - Public

2940118 - Visit Duration in Tickets

Symptom

When creating a Visit from a Ticket, the Visit Duration is set to 1 day instead of the duration maintained in the Business Configuration.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work centre.
  2. Go to the Tickets view.
  3. Open any Ticket
  4. Go to the Facet: Visits
  5. Click New to create a new Visit 

Result: the Visit starts on 14.6 00:00 and ends on 15.6. 00:00 (example date).

Expected: The Visit duration is set to 30 min in the Business Configuration hence 30 min should be the default duration.

Cause

As per the code, the visit duration maintained in BC is not valid for Tickets as the scenario is creating the visit with the reference from the ticket. So we take the parameters from the Tickets and fill the fields in the Visit Quick Create.

Here, we fill the Startdate time and Enddate time as that of Service Ticket's timepoint period, which is 1 day.

Resolution

This is the system behaviour.

Keywords

visit duration, ticket, business configuration, default, day, minutes , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions